RyanTeck RTK-000-001

This motor controller board http://www.raspberrypi.org/archives/5269 gives full control over 2 motors and is one of the simplest ways to get into Robotics on the Raspberry Pi.

RtkDocsTo use it in ScratchGPIO, simple set variable AddOn to RTKRPiMCB and then you can use 2 variables – Motor1 and Motor 2 and vary the speed and direction of the motors from -100 to 100.

It also breaks out the 3.3V, GND and the I2C pins so it you can add on other I2C devices as well.

 

11 thoughts on “RyanTeck RTK-000-001

  1. Hi Simon,
    I followed your instructions to use the Ryanteck board with GPIO version 5 but I couldn’t get the motors to run. I set up a variable called AddOn and then used it in ” set AddOn to RTKMotorMotorCon” but couldn’t see the next line of the scratch display on your utube demo. I tried both “broadcast AllOff and broadcast nAddOn” but neither of them worked. Then, at the bottom of your text it said that this feature was only available in the development version and I am running GPIO 5
    Another problem was after I installed your “setting up x11vnc” I couldn’t connect.
    Do I need to initialise the server in some way? When I tried typing x11vnc in the terminal it gave a warning that there was no password although I had set one in the setup process. Is there anyway of removing x11vnc as my previous set using VNC-server no longer works either and it was before I tried your setup.
    Sorry to be such a pain but I did read all the instructions, honest!
    Regards
    Alan

    • Em – I don’t know if my code has gone wrong for Ryan’s board as can’t currently find it in anywhere to test 😦
      But do you have anything else to try ScratchGPIO out on@?
      On the x11vnc front, I have never un-installed it so your guess is as good as mine (apt-get remove x11vnc?? and delete x11vnc from /home/pi/.config/autostart)
      It wasn’t intended to be run alongside another VNC server install though 😦

      Sorry your having all this trouble – some people seem to be just a lot more unlucky than others 😦

      Simon

      • Hi Simon
        Long story!
        I gave my 12 yrs old Grandsonb, who lives near Geneva, a RPi for Christmas because his International school did not do RPi’s or scratch. I have badgered the school into teaching Scratch (on pc’s) but I need to convince them that RPi’s are worth the cost as they will drive lamps and motors and sensors. My G/S is staying with me in England next week and I was hoping he would be able to take back his RPi mounted on the cheap 3 wheeled Chinese yellow buggy.
        I have got it working with a python script following a set program but needed to demonstrate exactly what you did on your Utube video, so anything at all you can think of by tomorrow week would be an enormous help to get some RPi’s into his school. No pressure then!
        As I said the board works with a python script via SSH and I did an apt-get update and upgrade but still nothing.
        I made a variable called AddOn and “set it to RTKMotorCon”and the made two variables “motor1” & “motor2”
        After that it is difficult to read the Utube screen but I think you did “broadcast AllOff”
        And then “set motors 1&2 to zero”
        If that is correct, that is what I did.
        So, if you can possibly help I will be extremely grateful.
        For what it’s worth, in your description of running stepper motors in you GPIO script you use a UN2008 Darlington ic but if you use a UN2308 you get 8Darlington outputs instead of 7 and can hence drive two steppers with only one chip!
        Regards
        Alan

      • Apologies _ i don;t know why but my code is looking for addon = rtkrpimcb not rtkmotorcon
        I don’t know if documentation is wrong or code is wrong until I speak to RyanTeck
        I just tried it out at my end and it works OK:)

        Ref 2308 vs 2003 ULN chip – a Lot of Stepper motors come with a ULN2003 driver board so its cheaper (and its also easier to wire up) to use the free ULN2003s rather than buying a 2008 🙂

        Simon

    • I’ve just tried my x11vnc script on a fresh virgin SD card image and it worked fine – the only thing I can think of is you do need to reboot afterwards and it doesn’t say to do that so I’ll add that in 🙂

  2. Hi Simon,
    You have just made my day.
    I put in the new text and everything worked!
    All I have to do now is to get my IPad to act as a viewer for the Pi with scratch.
    As I mentioned I tried x11vnc but that, somehow or other stopped my previously working VNC with a PC laptop, so I had to use another noobs card and used tight VNC.
    By the way how can I find out which version of GPIO I am using.
    Once again thanks for all your help.
    PS. If you ever need to fly out of Heathrow for a
    Holiday you can leave your car at my place which is
    ten mins from T5. Please don’t publish this as I shall
    Inundated with requests.
    TTFN
    Alan

    • I don’t think it’s possible to mix and match. VNC server software. And I don’t use Noobs so I haventt tested my script on it so I’ll have to give it a go
      What do you mean by GPIO version?
      I live in lancs but thanks for offer of parking 🙂

  3. Hi Simon
    The GPOI Version I was referring to was to find out if I had downloaded the dev version or the latest version.
    I have a printed doc by you, saying “”This post is to hopefully document all the available broadcasts and variable usage that ScratchGPIO understands and responds to”
    In it are various examples and the 4th one down says
    “Broadcast-version”
    “Say-Version-sensor value for 2-secs”
    Then it says (to)”Get ScratchGPIO version”
    However I can’t find a block saying
    “Say xxxxxxx sensor value for x secs”
    So I can’t find out which version I have or which date and time or which pin value etc.
    I am afraid I can’t remember where I got it from!
    Anyway thanks again for all your help – I don’t suppose you have done anything for “PiFace Digital” by any chance?

    TTFN

    Alan

  4. Sorry Simon,
    I get the sensor value bit now,
    On my grotty printout I couldn’t see that the “sensor value was another box inserted into the “say” command so now I understand.
    I must get some new cartridges!
    TTFN
    ALAN

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s